IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Discogs track tags not loading
blackbeen
post Dec 8 2011, 07:54
Post #1


Member


Group: Full Members
Posts: 26
Joined: 28-August 11
From: Toledo, OH USA
Member No.: 15146
Mp3tag Version: v2.58



When I load a release it reads like this: with no tag data I tried a number of releases including one I tagged just yesterday. I tried tagging app TagScanner & it loads ok.
Go to the top of the page
 
+Quote Post
pone
post Dec 8 2011, 12:32
Post #2


Member


Group: Full Members
Posts: 1688
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



what script are you using?

mine http://forums.mp3tag.de/index.php?showtopic=10431
& dano's http://forums.mp3tag.de/index.php?showtopic=2141
are working.
Go to the top of the page
 
+Quote Post
blackbeen
post Dec 8 2011, 13:36
Post #3


Member


Group: Full Members
Posts: 26
Joined: 28-August 11
From: Toledo, OH USA
Member No.: 15146
Mp3tag Version: v2.58



QUOTE (pone @ Dec 8 2011, 13:32) *


The freak one, yeah I tried one of the others reads kinda different though.

Attached File(s)
Attached File  Discogs_ID.src ( 7.44K ) Number of downloads: 108
 
Go to the top of the page
 
+Quote Post
pone
post Dec 8 2011, 14:00
Post #4


Member


Group: Full Members
Posts: 1688
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



ZITAT(blackbeen @ Dec 8 2011, 13:36) *
The freak one, yeah I tried one of the others reads kinda different though.


Where is that from? I can't find it in the forum.

I will have a look, if it some simple thing I will fix it.

It uses Discogs API 1.0. This will be shut down in a few days anyway. So it has to be adopted to API 2.0
more about that here: http://forums.mp3tag.de/index.php?showtopi...ost&p=58236
Go to the top of the page
 
+Quote Post
blackbeen
post Dec 8 2011, 14:21
Post #5


Member


Group: Full Members
Posts: 26
Joined: 28-August 11
From: Toledo, OH USA
Member No.: 15146
Mp3tag Version: v2.58



QUOTE (pone @ Dec 8 2011, 15:00) *
Where is that from? I can't find it in the forum.

I will have a look, if it some simple thing I will fix it.

It uses Discogs API 1.0. This will be shut down in a few days anyway. So it has to be adopted to API 2.0
more about that here: http://forums.mp3tag.de/index.php?showtopi...ost&p=58236


I thought it was one of the default scripts that came with the app, I'm not certain at this point, I like that it reads in the main Tag Sources menu rather than a sub its a little quicker to access that way.
Go to the top of the page
 
+Quote Post
pone
post Dec 8 2011, 14:23
Post #6


Member


Group: Full Members
Posts: 1688
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



I've got.

It seems like discogs introduced a new ID for every artist at the API pages. Just had to replace this and it worked again. I also adapted the URL to API 2.0


CHANGE LOG:

changed this line:
[IndexUrl]=http://www.discogs.com/release/%s?f=xml&api_key=1e48c7f4e4
into this:
[IndexUrl]=http://api.discogs.com/release/%s?f=xml

and added this line:
regexpreplace "<id>\d+?</id>" ""

EDIT:
It's certainly not one of the default scripts.

This post has been edited by dano: Dec 8 2011, 16:11
Attached File(s)
Attached File  Discogs_ID_by_freak_reworked_by_pone.src ( 7.48K ) Number of downloads: 123
 
Go to the top of the page
 
+Quote Post
blackbeen
post Dec 8 2011, 14:43
Post #7


Member


Group: Full Members
Posts: 26
Joined: 28-August 11
From: Toledo, OH USA
Member No.: 15146
Mp3tag Version: v2.58



QUOTE (pone @ Dec 8 2011, 15:23) *
I've got.

It seems like discogs introduced a new ID for every artist at the API pages. Just had to replace this and it worked again. I also adapted the URL to API 2.0


CHANGE LOG:

changed this line:
[IndexUrl]=http://www.discogs.com/release/%s?f=xml&api_key=1e48c7f4e4
into this:
[IndexUrl]=http://api.discogs.com/release/%s?f=xml

and added this line:
regexpreplace "<id>\d+?</id>" ""

EDIT:
It's certainly not one of the default scripts.


I receive a bad request error now.
Attached thumbnail(s)
Attached Image
 
Go to the top of the page
 
+Quote Post
pone
post Dec 8 2011, 15:04
Post #8


Member


Group: Full Members
Posts: 1688
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



I'll be back in two hours.
Go to the top of the page
 
+Quote Post
dano
post Dec 8 2011, 16:12
Post #9


Moderator


Group: Moderators
Posts: 5688
Joined: 4-September 03
From: Germany
Member No.: 201
Mp3tag Version: 2.65



I've fixed the attachment of pone.
It seems # Comments don't work in [IndexUrl] line.


--------------------
Go to the top of the page
 
+Quote Post
blackbeen
post Dec 8 2011, 17:28
Post #10


Member


Group: Full Members
Posts: 26
Joined: 28-August 11
From: Toledo, OH USA
Member No.: 15146
Mp3tag Version: v2.58



QUOTE (dano @ Dec 8 2011, 17:12) *
I've fixed the attachment of pone.
It seems # Comments don't work in [IndexUrl] line.


Thanks, works fine smile.gif

This post has been edited by blackbeen: Dec 8 2011, 17:29
Go to the top of the page
 
+Quote Post
pone
post Dec 8 2011, 17:57
Post #11


Member


Group: Full Members
Posts: 1688
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



ZITAT(dano @ Dec 8 2011, 16:12) *
I've fixed the attachment of pone.
It seems # Comments don't work in [IndexUrl] line.


thanks dano
Go to the top of the page
 
+Quote Post
pone
post Dec 8 2011, 19:21
Post #12


Member


Group: Full Members
Posts: 1688
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



ZITAT(blackbeen @ Dec 8 2011, 18:28) *
Yeah, but unfortunately that puts A1, A2... after the track title rather than in the track number field like the other script I was using, I was trying to avoid this, as is its quicker to manually edit the Track field from 01/04 to A1 than editing A1 off the end of the title field as I have been doing, thinking it was a problem on Discogs end.


no, I wasn't talking about my fix of freak's script, I was talking about this:
http://forums.mp3tag.de/index.php?showtopic=10431
there you freely decide what tag field you want for every little bit of information.
+ you get 15 different ways to search for your release from mp3tag, you don't have to look it up in the browser before to get the release id


about freak's script:
I noticed that strange behaviour for the TITLE field, but I kept it as you mentioned nothing about it.
Here is a quick fix for it:
- I removed the tracknumber from the end of the TITLE field
- I deleted the VINYL# field
- I added a little code at the end which replaces the standard track numbers with the track postions from discogs for all releases with the following media formats at discogs:
Vinyl|Cassette|Acetate|Shellac|Microcassette|Lathe Cut
Attached File(s)
Attached File  Discogs_ID_by_freak__pone_rework_2.src ( 7.22K ) Number of downloads: 124
 
Go to the top of the page
 
+Quote Post
blackbeen
post Dec 8 2011, 19:28
Post #13


Member


Group: Full Members
Posts: 26
Joined: 28-August 11
From: Toledo, OH USA
Member No.: 15146
Mp3tag Version: v2.58



QUOTE (pone @ Dec 8 2011, 19:21) *
no, I wasn't talking about my fix of freak's script, I was talking about this:
http://forums.mp3tag.de/index.php?showtopic=10431
there you freely decide what tag field you want for every little bit of information.
+ you get 15 different ways to search for your release from mp3tag, you don't have to look it up in the browser before to get the release id


about freak's script:
I noticed that strange behaviour for the TITLE field, but I kept it as you mentioned nothing about it.
Here is a quick fix for it:
- I removed the tracknumber from the end of the TITLE field
- I deleted the VINYL# field
- I added a little code at the end which replaces the standard track numbers with the track postions from discogs for all releases with the following media formats at discogs:
Vinyl|Cassette|Acetate|Shellac|Microcassette|Lathe Cut


Thanks, works perfect smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 20:39