IPB

Welcome Guest ( Log In | Register )

> Notice!

Please take a minute to check our Frequently Asked Questions. Use Search to reveal possible related topics.

Also make sure you've read the Forum Guidelines before posting in this forum.

> Potential bug when exporting to txt ?
pastic
post Feb 8 2012, 20:56
Post #1


Member


Group: Members
Posts: 4
Joined: 6-February 12
Member No.: 16032
Mp3tag Version: 2.48



Hi,
I do not file a bug report proper because I dare not try to reproduce the bug, but I will report it here anecdotally.
I exported tags for 1084 files to mp3tag.txt. I used the default txt-file profile, but have adapted the fields to export and custom field separators. I have used this template a zillion times without problem, also on similarly large collections. Basically I use this template when I for some reason need to transcode between lossless formats but keep the tags or when other tag mysterious problems arise that require cleaning all tags and then writing them back tot he files.

So the process is a mere exporting the tags - removing all tags - reapplying the tags from the exported file.

But this time the exported files was all hodgepodge. After like 300 files entries started to switch position in the list, i.e., tags for files 325-330 were exported to position 304-309, so when reapplying them they were applied to the wrong files and the more further down the list the more chaos reigned.

One peculiar aspect of order in the chaos was that albums wre kept intact. Files from one album would not be scattered all over or separated from each other but they would be moved as a group to a new location between two other albums. Whether in fact this is due to album tags or position on the harddrive I cannot tell because albums and harddrive folders co-incide.

Thank god for the undo command which restored all tags.

But I want to point you attention to this potential problem when exporting tags.

Let me know if you need more info.

This post has been edited by pastic: Feb 8 2012, 21:03
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 2)
pone
post Feb 8 2012, 21:07
Post #2


Member


Group: Full Members
Posts: 1688
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



ZITAT(pastic @ Feb 8 2012, 20:56) *
Hi,
I do not file a bug report proper because I dare not try to reproduce the bug, but I will report it here anecdotally.


If you don't try to reproduce, we will never find out what went wrong.
There is no risk in exporting the textfile again and again. As long as you don't reimport the data, nothing gets mixed up.
Have you checked the txt file? Do you use the filepath for reimport? Or just in the order of sorting in Mp3tag? Maybe the files were sorted different at export and reimport.
Go to the top of the page
 
+Quote Post
ohrenkino
post Feb 8 2012, 21:14
Post #3


Member


Group: Full Members
Posts: 4785
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.65a



could it be that a tag field has a control character e.g. a linebreak? The export only works alright for visible characters.


--------------------
42 - wie war die Frage / what was the question / comment était la question
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 15:17