IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> [X] Problem with Mp3tag reading tags of mp3 files, When a read a mp3 file, the title, artist, album tags don't appear
chchbrs
post Mar 25 2012, 17:22
Post #1


Member


Group: Members
Posts: 2
Joined: 25-March 12
Member No.: 16245
Mp3tag Version: 2.50



Hello.

I've used mp3tag for 5 years ago, and I've never happened this. When a read a mp3 file, the tag file says IDE3v1, IDEv2.3, APE, but the title, artist, track, album fields appear empty. I try filling the fields again, but it doesn't appear. The only solution is to unistall and reinstall the program, and it works fine, but the problem persist. How can I resolve this??? thanks!!!
Go to the top of the page
 
+Quote Post
ohrenkino
post Mar 25 2012, 17:51
Post #2


Member


Group: Full Members
Posts: 4875
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.65a



ZITAT(chchbrs @ Mar 25 2012, 17:22) *
... read a mp3 file, the tag file says ... APE...

I guess the problem are the APE tags.
Go to Tools>Options>MPEG and switch off reading and writing APE but switch on deleting APE tags.
APE tags overrule MP3 tags so if there is nothing in the APE tags then you don't see anything in MP3tag.

To get rid of the the APE tags, select the files in the files list, then cut the tags with the function from the context menu and paste then immediately afterwards (use small portions of files so that if the computer reboots between cutting an pasting and the data in the clipboard is lost, not too much damage is done).

You find the files with APE tags if you apply the filter
%_tag% HAS APE.


--------------------
42 - wie war die Frage / what was the question / comment était la question
Go to the top of the page
 
+Quote Post
m4rk
post Jul 10 2013, 08:39
Post #3


Member


Group: Full Members
Posts: 21
Joined: 21-November 11
Member No.: 15609
Mp3tag Version: 2.49



QUOTE (ohrenkino @ Mar 25 2012, 17:51) *
I guess the problem are the APE tags.
Go to Tools>Options>MPEG and switch off reading and writing APE but switch on deleting APE tags.
APE tags overrule MP3 tags so if there is nothing in the APE tags then you don't see anything in MP3tag.

To get rid of the the APE tags, select the files in the files list, then cut the tags with the function from the context menu and paste then immediately afterwards (use small portions of files so that if the computer reboots between cutting an pasting and the data in the clipboard is lost, not too much damage is done).

You find the files with APE tags if you apply the filter
%_tag% HAS APE.



This caught me out too... Blank fields were showing where artist etc should be. Filling the fields directly and mp3tag appeared not save the new values.

The fix is in the mpeg tags setting, under tools, to disable read for APE (or enable write for APE to edit the blank APE field). The problem is APE has a pre-defined higher priority than ID3 for displaying the read tags. If the APE tags are blank then that is what you will see.

After googling I find that several users have been perplexed by this issue. It would be good if the priority of the tag types for display is indicated, and maybe make the priority user adjustable
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd November 2014 - 20:50