IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> [F] Problems saving on a network drive in Windows Vista
Stephan Wentz
post Apr 6 2007, 13:02
Post #1


Member


Group: Members
Posts: 3
Joined: 6-April 07
Member No.: 4728
Mp3tag Version: 2.37a



Hi all!

Recently I installed Vista, everything works fine (more or less, hehe), but I can't get MP3tag to change mp3-files on a network drive (the server is reached via samba on linux). Renaming files works fine, but when I want to save changes or remove tags I'm only getting a "Konnte nicht zum Schreiben geöffnet werden"-error (can't open file for writing).

Access right are ok, I tried it with a hex-editor, I can write away without any problems.

Any thoughts on this one? Btw, I tried the newest development-build, same problem...

Bye, Stephan
Go to the top of the page
 
+Quote Post
Florian
post Apr 15 2007, 13:42
Post #2


Developer


Group: Admin
Posts: 7728
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.65a



Hi Stephan,

I've just tried it with a standard windows share and it works without problems.

Kind regards,
Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
nickless
post Apr 16 2007, 20:44
Post #3


Member


Group: Full Members
Posts: 383
Joined: 9-August 04
From: Germany
Member No.: 1114
Mp3tag Version: 2.49



QUOTE (Stephan Wentz @ Apr 6 2007, 14:02) *
Any thoughts on this one?

You could also look at samba logs on linux side to see if it reports some error.

Regards
nickless


--------------------
My Exports

/(bb|[^b]{2})/ that is the question...
user posted image - emerge the world
Go to the top of the page
 
+Quote Post
Stephan Wentz
post May 29 2007, 23:03
Post #4


Member


Group: Members
Posts: 3
Joined: 6-April 07
Member No.: 4728
Mp3tag Version: 2.37a



QUOTE (nickless @ Apr 16 2007, 21:44) *
You could also look at samba logs on linux side to see if it reports some error.

Regards
nickless


Just installed mp3tag 2.38 to see if the problems got better - but no chance.
Still the same problems here, can't write id3-tags to a samba-mounted network drive.

Client OS is Vista Home Premium German, with mp3tag version 2.38
Server OS is Gentoo Linux with a 2.6.19 kernel, with samba version 3.0.24

Here is the relevant stuff from the samba log, log-level 2.

CODE
[2007/05/29 23:52:26, 2] smbd/open.c:open_file(352)
  temp opened file audio/mp3/xxxxx/01 - xxxxx.mp3 read=Yes write=No (numopen=18)
[2007/05/29 23:52:26, 2] smbd/close.c:close_normal_file(344)
  temp closed file audio/mp3/xxxxx/01 - xxxxx.mp3 (numopen=17)
[2007/05/29 23:52:27, 2] smbd/open.c:open_file(352)
  temp opened file audio/mp3/xxxxx/01 - xxxxx.mp3 read=Yes write=No (numopen=18)
[2007/05/29 23:52:27, 2] smbd/close.c:close_normal_file(344)
  temp closed file audio/mp3/xxxxx/01 - xxxxx.mp3 (numopen=17)


Even on higher Log-Levels no errors can be found. What I don't understand, why does it state "write=No"? Does it mean that he CAN'T write or that he doesn't WANT to write?

I have _one_ other application that behaves the same - the free text-editor pspad. This one can't write to my linux-shares, too. I tried it with notepad++, this one worked like a charm.

But back to mp3tag, I tried it with 2 other ID3-Tag-Editors (thegodfather and TagScanner), both worked right away. Here is an excerpt from the logfile when writing with TagScanner:

CODE
[2007/05/30 00:03:48, 2] smbd/open.c:open_file(352)
  temp opened file audio/mp3/xxxxx/01 - xxxxx.mp3 read=Yes write=Yes (numopen=14)


It says "write=Yes", beaneath about 15 other open/closes of the same file with "write=No". mp3tag only does 4 open/closes...

So maybe there was some kind of a change in Vistas network code or something? That there has to be done something different to open files from a network drive? I'm clueless sad.gif

Is there anyone with my given configuration, Vista on client and Samba on the server side?

Hope we get this solved... Don't want to change my favorite id3-tagger ;-)

Bye, Stephan
Go to the top of the page
 
+Quote Post
Florian
post Jun 3 2007, 12:26
Post #5


Developer


Group: Admin
Posts: 7728
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.65a



I'm on vacation from today till June 11, but I'll look at the problem again when I'm back.

Kind regards,
Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
BradW
post Jun 4 2007, 11:38
Post #6


Member


Group: Members
Posts: 3
Joined: 26-May 07
Member No.: 4992
Mp3tag Version: 2.38a



Hi Florian,

I'm getting the "cannot open file for writing error" on most MP3s under Vista Home Premium using a Standard User account (User Account Control turned off). If I edit the tag with an admin account, it works fine. AND, after editing with an admin account, I can then edit that tag with the Standard User account. No network share involved; this is all happening on the Vista machine.

HTH,

Brad
Go to the top of the page
 
+Quote Post
Stephan Wentz
post Jun 6 2007, 08:45
Post #7


Member


Group: Members
Posts: 3
Joined: 6-April 07
Member No.: 4728
Mp3tag Version: 2.37a



QUOTE (BradW @ Jun 4 2007, 12:38) *
Hi Florian,

I'm getting the "cannot open file for writing error" on most MP3s under Vista Home Premium using a Standard User account (User Account Control turned off). If I edit the tag with an admin account, it works fine. AND, after editing with an admin account, I can then edit that tag with the Standard User account. No network share involved; this is all happening on the Vista machine.

HTH,

Brad


Hi Brad, is the share you're writing to on the same machine? Or on another computer's share?

My problem isn't solved with Admin-Rights, but I haven't tried turning off UAC yet. I'll try that and report...

Bye, Stephan
Go to the top of the page
 
+Quote Post
BradW
post Jun 11 2007, 09:21
Post #8


Member


Group: Members
Posts: 3
Joined: 26-May 07
Member No.: 4992
Mp3tag Version: 2.38a



Hi Stephan,

Not a share at all. Just using Mp3tag on my Vista machine, logged in as a standard user.

I have come to the conclusion that Vista is not READY yet. Too many problems; this one, much hassle with iTunes and others! Oh well! Don't recommend that anyone upgrade to Vista yet, unless they have to. sad.gif

Still no solution to the Mp3tag issue, either. sad.gif

Brad
Go to the top of the page
 
+Quote Post
Florian
post Jun 16 2007, 21:12
Post #9


Developer


Group: Admin
Posts: 7728
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.65a



The problem with saving to Samba shares should be fixed with the latest Development Build.

Kind regards,
Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
ken
post Jul 31 2007, 14:39
Post #10


Member


Group: Full Members
Posts: 7
Joined: 29-June 07
Member No.: 5190
Mp3tag Version: 2.38



I have my audio files on a 500G external Hard Drive and have been making changes to my filenames using the Convert Action feature (wonderful by the way). I have two systems using Vista.

When I perform this action over the network, I end up with some filenames changed to tmp....

When I perform this action not over the network having the external drive hooked up via ESATA, all is well.

I'm sharing this information in hopes that the developer(s) may find this information helpful.

Great Job!

Ken

PS I wish someone within Microsoft could have deleted the Vista Source code. Vista is becoming more annoying to me every day.

This post has been edited by ken: Jul 31 2007, 14:43
Go to the top of the page
 
+Quote Post
Chuck
post Aug 16 2007, 15:35
Post #11


Member


Group: Full Members
Posts: 19
Joined: 25-July 07
Member No.: 5328
Mp3tag Version: 2.59a



I am seeing the same problem where intermittently a file can't be changed over the network from a Vista machine. I have noticed it only occurs with large files it is trying to modify tags on. I always get a tmp file being placed in the directory. I am using 2.39. Any ideas?
Go to the top of the page
 
+Quote Post
GHammer
post Aug 17 2007, 04:47
Post #12


Member


Group: Full Members
Posts: 10
Joined: 7-April 06
Member No.: 2981
Mp3tag Version: 2.65



Have you applied the latest updates for Vista, the Vista Compatibility, Performance and Reliability patches?

Have you tried this from an Administrator command window?

CODE
netsh int tcp set global autotuninglevel=disable


That command will disable Vista's auto tuning feature which can/does cause problems especially on LAN throughput.

Finally, Vista has the same 10 half open connection limit as XP SP2.
You may be getting a block on TCP/IP, have you checked system event logs?

The Vista limit is harder to work around but it can be done.
Go to the top of the page
 
+Quote Post
cameron
post Aug 17 2007, 18:46
Post #13


Member


Group: Members
Posts: 1
Joined: 17-August 07
Member No.: 5467
Mp3tag Version: 2.39



So.. I have this exact problem under XP.

I am running version 2.39 now... and Re tagging works fine on local hard drives in my XP machine.

BUT when I try to change files on my Ubuntu machine (samba, of course) I get the write error noted above, and the TMP files noted above.

I have no problems with permissions outside of mp3 tag.

can it be solved?

c
Go to the top of the page
 
+Quote Post
RamessesIV
post Apr 21 2009, 11:38
Post #14


Member


Group: Members
Posts: 1
Joined: 21-April 09
Member No.: 9848
Mp3tag Version: v2.43



Got the same problem with my Vista Enterprise; but with v2.43.
Solved my problem by alternate click on icon and choosing the option "runs as administrator", works fine now.
Go to the top of the page
 
+Quote Post
joep
post Jan 5 2010, 02:12
Post #15


Member


Group: Members
Posts: 1
Joined: 5-January 10
Member No.: 11612
Mp3tag Version: 2.45a



Florian... why is this topic in the 'Fixed Bugs' forum?

I have the same problem. My mp3 files are in a NAS (D-Link DNS323, aka samba with Ext2). When I tried to modify the tags of a big mp3 file (appr. >10MB), I got an error message:

"File m:\\folder\big.mp3 cannot be opened for writing"

The result is a tmp file in the folder, almost the same size as the original file. The 'Basic info' was filled, half of the ID3v1 fields were filled, other half are empty, and the ID3v2 fields are empty as well.

I tried the 'run as admin' method, but the NAS authenticates me, so I have to use the NAS user/pw - the result was the same error.

I tried to modify this tags with Winamp - through the network - and there wasn't any problem. So I think, it is definitely not samba problem, not Vista problem, not UAC problem, not permission problem - it is the problem of the mp3tag program. (Because the Winamp works well in the very same environment, without any tricks.)

When I copied that big mp3 file into the local disk, the mp3tag changed the tags without any problem.

I set the network timeot to 9999999 in the tools menu of the mp3tag.

In the NAS I don't use the jumbo frames option.

I use the 2.45a version of the program.

It is only at the first sight a little problem. The sizes of my mp3 files mostly bigger than 10 MB. Now, when I want to make tidy in my audio library, I have to copy that 1xx GB into my local disk - and then back?
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 16:02