Help - Search - Members - Calendar
Full Version: Trouble saving album art to files
Mp3tag Forums > Mp3tag - International > Support
lsuben
I have been trying to organize my music for a while now and so far I love Mp3tag.

One small bump I'm hitting is causing the album art not to be saved to a particular file in an album.

Example: I open a folder (one album) in Mp3tag and select all of the files (songs) contained therein. I then right click on the album art field and select "Add Cover...". I select the image I want to use and then click Save. The progress box shows all of the files being saved and then I even get positive confirmation that X out of X files were saved. However, upon inspecting each file I find that some files have not had the image saved. In other words, despite the confirmation message saying that all of the files were saved properly, clearly some are not. I would say that generally two to four files do not save the image properly. Sometimes more than that save inappropriately, and sometimes they all do.

Now this is by no means a deal breaker. The program is smooth and effective. Plus, all I have to do to fix the problem is to go into each file, add the image again and save them individually. I would, however, love to figure what I'm doing wrong.

If it helps, I'm using v. 2.44 on Windows XP. The album art is always .jpg, and the media files are probably evenly split between .mp3 and .wma.

Also, I tried searching using terms like "cover varies", "cannot save", and the like and got oodles and oodles of returns. If this has been answered before, I do apologize.

Thanks in advance.
DetlevD
QUOTE (lsuben @ Oct 2 2009, 23:54) *
... However, upon inspecting each file I find that some files have not had the image saved. In other words, despite the confirmation message saying that all of the files were saved properly, clearly some are not. ...

There might be a cover in the file already, which is of zero size or otherwise corrupted, so that importing cannot be done successfully by Mp3tag.
Before you want to import any new cover image to such a file you should remove any embedded cover. Afterwards load the new cover and see what happens.

DD.20091003.1013.CEST
lsuben
QUOTE (DetlevD @ Oct 3 2009, 01:13) *
There might be a cover in the file already, which is of zero size or otherwise corrupted, so that importing cannot be done successfully by Mp3tag.
Before you want to import any new cover image to such a file you should remove any embedded cover. Afterwards load the new cover and see what happens.

DD.20091003.1013.CEST
I've tried it and it's still funky.

As a side note, if I copy/paste the files (songs) out of the folder they're in into a new folder, THEN remove all tags, I can import tags and album art as easily and flawlessly as before.
Nine6Teen
QUOTE (lsuben @ Oct 3 2009, 07:23) *
I've tried it and it's still funky.

As a side note, if I copy/paste the files (songs) out of the folder they're in into a new folder, THEN remove all tags, I can import tags and album art as easily and flawlessly as before.


Hi ... I have the same problem. Often times, none of the Cover art sticks. Any help/suggestions would be greatly appreciated.
Florian
Are you using some antivirus software that might be blocking the file update?
Erstam
I'm having exactly the same issue. In most cases, only 2/3 of album covers are really saved. And if I retry, the files that get album covers stored with them are not even consistent. Sometimes saving covers to a file removes the previous cover but does not add any new cover.

I observed this behaviour in all versions till now (v2.45a).

Is there any solution or anything I can do to track this?

Best regards,

Erstam
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.