Help - Search - Members - Calendar
Full Version: [F] Losing path and filename
Mp3tag Forums > Mp3tag - International > Development
Rijkstra
I believe this problem started with v2.23o. I keep losing the filename and path as soon as I click on a file and get a save error because I am saving to a filename with a null string. I uninstalled/reinstalled v2.23q and the problem went away, but so did a lot of my settings, so I resurrected a copy of Mp3tag.reg I saved just before I uninstalled and restored it. The problem is back and Mp3tag is not useable. I'll try to send you the REG file.

P.S. I repeated the uninstall/reinstall of v2.23q and this time edited the registry file I sent to Florian via email to restore only those things that I really needed, mostly lists and the sequence of my actions. The program does not lose the filename or path of selected files and is back to normal.
Florian
Sorry, I can't reproduce the problem here.

It would be great, if you can find a way to reproduce the problem with the latest Development Build. Maybe it's caused by a special sequence of functions executed!?

Best regards,
~ Florian
Rijkstra
QUOTE (Florian @ Aug 14 2004, 12:55 AM)
Sorry, I can't reproduce the problem here.

... Maybe it's caused by a special sequence of functions executed!?

Best regards,
~ Florian

I don't think so, because when the problem was there, the first thing I did going in was to click on a file. Immediately the filename and path fields went blank. Trying to save the tag showed that those fields were blank in every way. I suspect this entry in the registry:

[HKEY_CURRENT_USER\Software\Moebius\Mp3tag\Settings]
"TagFields"="ALBUM BPM COMPOSER GENRE COPYRIGHT DATE
PLAYLISTDELAY ENCODEDBY LYRICIST FILETYPE TIME CONTENTGROUP
TITLE SUBTITLE INITIALKEY LANGUAGE SONGLEN MEDIATYPE
ORIGALBUM ORIGFILENAME ORIGLYRICIST ORIGARTIST ORIGYEAR
FILEOWNER ARTIST BAND CONDUCTOR MIXARTIST PARTINSET
PUBLISHER TRACK RECORDINGDATES NETRADIOSTATION
NETRADIOOWNER SIZE ISRC ENCODERSETTINGS YEAR
UNSYNCEDLYRICS INVOLVEDPEOPLE USERTEXT COMMENT
WWWAUDIOFILE WWWARTIST WWWAUDIOSOURCE
WWWCOMMERCIALINFO WWWCOPYRIGHT WWWPUBLISHER WWWPAYMENT
WWWRADIOPAGE WWWUSER"

Which had different delimiters before:

[HKEY_CURRENT_USER\Software\Moebius\Mp3tag\Settings]
"TagFields"="ALBUM\ARTIST\BAND\BPM\COMMENT\COMPOSER\CONDUCTOR
\CONTENTGROUP\COPYRIGHT\DATE\ENCODEDBY\ENCODERSETTINGS
\FILEOWNER\FILETYPE\GENRE\INITIALKEY\INVOLVEDPEOPLE\ISRC\LANGUAGE
\LYRICIST\MEDIATYPE\MIXARTIST\NETRADIOOWNER\NETRADIOSTATION
\ORIGALBUM\ORIGARTIST\ORIGFILENAME\ORIGLYRICIST\ORIGYEAR\PARTINSET
\PLAYLISTDELAY\PUBLISHER\RECORDINGDATES\SIZE\SONGLEN\SUBTITLE\TIME
\TITLE\TRACK\UNSYNCEDLYRICS\USERTEXT\WWWARTIST\WWWAUDIOFILE
\WWWAUDIOSOURCE\WWWCOMMERCIALINFO\WWWCOPYRIGHT\WWWPAYMENT
\WWWPUBLISHER\WWWRADIOPAGE\WWWUSER\YEAR\"

Could I have gotten messed up by restoring the latter into a version that expects the first entry? The problem however, started before I ever tried to restore the registry. Could it possibly be a problem related to skipping a release that handled the delimiter change?
Florian
I've never changed anything regarding the delimiter handling of this TagField registry key - it's \v since the beginning.

But I've changed the whole filepath and folderpath handling to version 2.23i, so I guess that it has nothing to do with the registry settings.

Can you reproduce it with 2.23q?

Best regards,
~ Florian
Rijkstra
QUOTE (Florian @ Aug 14 2004, 08:27 AM)
I've never changed anything regarding the delimiter handling of this TagField registry key - it's \v since the beginning.

But I've changed the whole filepath and folderpath handling to version 2.23i, so I guess that it has nothing to do with the registry settings.

Can you reproduce it with 2.23q?

Best regards,
~ Florian

Yes, I can reproduce it by executing the Mp3tag.reg file I sent you. I have known some versions of REGEDIT to improperly write REG files. Is the file written to the registry or extracted from it?
Florian
QUOTE (Rijkstra @ Aug 14 2004, 08:38 AM)
QUOTE (Florian @ Aug 14 2004, 08:27 AM)
I've never changed anything regarding the delimiter handling of this TagField registry key - it's \v since the beginning.

But I've changed the whole filepath and folderpath handling to version 2.23i, so I guess that it has nothing to do with the registry settings.

Can you reproduce it with 2.23q?

Best regards,
~ Florian

Yes, I can reproduce it by executing the Mp3tag.reg file I sent you. I have known some versions of REGEDIT to improperly write REG files. Is the file written to the registry or extracted from it?

Thanks for pointing me to this problem. I did a code review for all parts in Mp3tag which are handling with filenames and found the bug which occured at least 7 times in the whole program and was caused by the change to the file view's column handling.

It had nothing to do with registry handling but with asking the GUI for filenames/foldernames (the file view) instead of querying them through the backend - duh, this code was from my early programming days rolleyes.gif

Thanks!
~ Florian

BTW: The bug should be fixed with the current Development Build and was a "Big Bug" this time wink.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.