Help - Search - Members - Calendar
Full Version: [X] Problem with Mp3tag reading tags of mp3 files
Mp3tag Forums > Mp3tag - International > Bug Reports > No Bugs
chchbrs
Hello.

I've used mp3tag for 5 years ago, and I've never happened this. When a read a mp3 file, the tag file says IDE3v1, IDEv2.3, APE, but the title, artist, track, album fields appear empty. I try filling the fields again, but it doesn't appear. The only solution is to unistall and reinstall the program, and it works fine, but the problem persist. How can I resolve this??? thanks!!!
ohrenkino
ZITAT(chchbrs @ Mar 25 2012, 17:22) *
... read a mp3 file, the tag file says ... APE...

I guess the problem are the APE tags.
Go to Tools>Options>MPEG and switch off reading and writing APE but switch on deleting APE tags.
APE tags overrule MP3 tags so if there is nothing in the APE tags then you don't see anything in MP3tag.

To get rid of the the APE tags, select the files in the files list, then cut the tags with the function from the context menu and paste then immediately afterwards (use small portions of files so that if the computer reboots between cutting an pasting and the data in the clipboard is lost, not too much damage is done).

You find the files with APE tags if you apply the filter
%_tag% HAS APE.
m4rk
QUOTE (ohrenkino @ Mar 25 2012, 17:51) *
I guess the problem are the APE tags.
Go to Tools>Options>MPEG and switch off reading and writing APE but switch on deleting APE tags.
APE tags overrule MP3 tags so if there is nothing in the APE tags then you don't see anything in MP3tag.

To get rid of the the APE tags, select the files in the files list, then cut the tags with the function from the context menu and paste then immediately afterwards (use small portions of files so that if the computer reboots between cutting an pasting and the data in the clipboard is lost, not too much damage is done).

You find the files with APE tags if you apply the filter
%_tag% HAS APE.



This caught me out too... Blank fields were showing where artist etc should be. Filling the fields directly and mp3tag appeared not save the new values.

The fix is in the mpeg tags setting, under tools, to disable read for APE (or enable write for APE to edit the blank APE field). The problem is APE has a pre-defined higher priority than ID3 for displaying the read tags. If the APE tags are blank then that is what you will see.

After googling I find that several users have been perplexed by this issue. It would be good if the priority of the tag types for display is indicated, and maybe make the priority user adjustable
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.