IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> [F] Discogs stopped working on 2.74
cpoink
post Feb 14 2016, 04:33
Post #1


Member


Group: Full Members
Posts: 5
Joined: 14-February 16
Member No.: 21727
Mp3tag Version: 2.74



Hi, my ssd died the other day and today installed a new copy of mp3tag but discogs is giving a oauth error saying it's invalid or timed out, downloaded a 2.73 from some random site to try on a virtual machine and it worked without any issues so guessing it's something with 2.74?

Could you post an official link for 2.73 please so i can install on my main machine until the issue is sorted?

Cheers

On the 1 or maybe 2 times that 2.74 discogs script didn't give invalid token while i was testing when entering the code on mp3tag would give a bad gateway error and not get added on discogs applications.

This post has been edited by cpoink: Feb 14 2016, 04:38
Go to the top of the page
 
+Quote Post
Florian
post Feb 14 2016, 07:19
Post #2


Developer


Group: Admin
Posts: 7863
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.82



Thanks for your report. Two additional questions:
  • Which version of Windows are you using?
  • Have you tried to uninstall Mp3tag (backup first, but including removing the configuration)?

The official link to v2.73 is
http://download.mp3tag.de/versions/mp3tagv273setup.exe

Kind regards
Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
cpoink
post Feb 14 2016, 07:49
Post #3


Member


Group: Full Members
Posts: 5
Joined: 14-February 16
Member No.: 21727
Mp3tag Version: 2.74



Thanks Florian, Windows 10 pro 64 bits.

Yeap i did try uninstalling 2 times and deleting %appdata%/mp3tag

Cheers for the link, i'll give it another try with 2.74 and report back for more info.

QUOTE (Florian @ Feb 14 2016, 08:19) *
Thanks for your report. Two additional questions:
  • Which version of Windows are you using?
  • Have you tried to uninstall Mp3tag (backup first, but including removing the configuration)?

The official link to v2.73 is
http://download.mp3tag.de/versions/mp3tagv273setup.exe

Kind regards
Florian

Go to the top of the page
 
+Quote Post
Florian
post Feb 14 2016, 08:49
Post #4


Developer


Group: Admin
Posts: 7863
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.82



Thanks!

Another attempt: Can you check your system time and make sure that it's correctly set?

Kind regards
Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
cpoink
post Feb 14 2016, 10:21
Post #5


Member


Group: Full Members
Posts: 5
Joined: 14-February 16
Member No.: 21727
Mp3tag Version: 2.74



Yeap, date is correct, just tried again with 2.7.4 with a fresh windows install and got the same issue.

Here's a screenshot with the exact error.

http://i.imgur.com/BUwycwB.png

and the sort of tokens it's generating in case it may help at all to see what could be wrong.

http://i.imgur.com/Ib6CaLp.png

QUOTE (Florian @ Feb 14 2016, 09:49) *
Thanks!

Another attempt: Can you check your system time and make sure that it's correctly set?

Kind regards
Florian


This post has been edited by cpoink: Feb 14 2016, 10:31
Go to the top of the page
 
+Quote Post
Florian
post Feb 14 2016, 11:44
Post #6


Developer


Group: Admin
Posts: 7863
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.82



Your second screenshot gave a good hint for the possible issue. Can you please try this version?

http://download.mp3tag.de/support/C6BCA44F...agv274setup.exe

Thanks!

Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
Hallucyn8
post Feb 14 2016, 11:52
Post #7


Member


Group: Members
Posts: 1
Joined: 14-February 16
From: England
Member No.: 21730
Mp3tag Version: 2.74



Hi

I have the same problem since updating to 2.74.

I have downloaded the version in the previous post and can confirm Discogs authorisation is now working.
Go to the top of the page
 
+Quote Post
cpoink
post Feb 14 2016, 11:57
Post #8


Member


Group: Full Members
Posts: 5
Joined: 14-February 16
Member No.: 21727
Mp3tag Version: 2.74



Testing now, and also figured so that's why i went back and added the second screenshot since figured it would be easier in case of for example the characters at the end not being intended heh.

Going to test it and will get back to you when done.

Thanks for the quick help.
QUOTE (Florian @ Feb 14 2016, 11:44) *
Your second screenshot gave a good hint for the possible issue. Can you please try this version?

http://download.mp3tag.de/support/C6BCA44F...agv274setup.exe

Thanks!

Florian


This post has been edited by cpoink: Feb 14 2016, 11:58
Go to the top of the page
 
+Quote Post
dj_estrela
post Feb 14 2016, 13:24
Post #9


Member


Group: Members
Posts: 1
Joined: 14-February 16
Member No.: 21732
Mp3tag Version: 2.74



I just had the exact same problem as the first poster; running the updated binary fixed this issue.
Thanks - and you just earned a donation!
Go to the top of the page
 
+Quote Post
cpoink
post Feb 14 2016, 13:34
Post #10


Member


Group: Full Members
Posts: 5
Joined: 14-February 16
Member No.: 21727
Mp3tag Version: 2.74



Yeap, working great in the new version Florian smile.gif, guess it was the weird chars at the end of the token? like last 3 or so.

Thank you very much for the quick fix smile.gif
QUOTE (Florian @ Feb 14 2016, 11:44) *
Your second screenshot gave a good hint for the possible issue. Can you please try this version?

http://download.mp3tag.de/support/C6BCA44F...agv274setup.exe

Thanks!

Florian

Go to the top of the page
 
+Quote Post
Florian
post Feb 14 2016, 14:02
Post #11


Developer


Group: Admin
Posts: 7863
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.82



Thank you all for reporting the issue and testing the fix. I've just release Mp3tag v2.74a, which fixes the issue officially.

And yes, cpoink, the issue was with those weird characters at the end of the token. This buffer was not correctly terminated smile.gif

Thanks again!

Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th May 2017 - 09:46