IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> [F] Discogs - Error >> 401 : UNAUTHORIZED
Akhlan
post Mar 17 2016, 11:44
Post #1


Member


Group: Full Members
Posts: 9
Joined: 15-February 16
Member No.: 21746
Mp3tag Version: 2.74a



Hi,

since one or two week, I have this error message when I want used discogs to tag my files...



I have change my C:\Users\xxxxxx\AppData\Roaming\Mp3tag\data\sources\discogs.src woth this

#[Encoding]=url-utf-8
[Encoding]=utf-8

but nothing best....

I used discogs.src [2016-01-31] v1.03

How resolve this issue ?

Rgds
akhlan
Go to the top of the page
 
+Quote Post
ohrenkino
post Mar 17 2016, 11:47
Post #2


Member


Group: Full Members
Posts: 9153
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.84d



Have you checked this report from just a month ago?

https://forums.mp3tag.de/index.php?showtopic=20858


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
Syldub
post Mar 18 2016, 23:46
Post #3


Member


Group: Full Members
Posts: 7
Joined: 10-November 14
From: France
Member No.: 20062
Mp3tag Version: 2.75



I also get the 401 error since few days. I spent more than 3 hours today to try to fix it, but failed.

---------------------------
Mp3tag v2.75
---------------------------
Error connecting to server: www.discogs.com

» 401: UNAUTHORIZED
---------------------------
Retry Cancel
---------------------------

This is a nightmare.
Go to the top of the page
 
+Quote Post
Rephlex
post Mar 19 2016, 09:04
Post #4


Member


Group: Full Members
Posts: 19
Joined: 6-April 10
Member No.: 12227
Mp3tag Version: 2.75



Getting the same error here.
Unable to search with the Pone or standard scripts.
All worked fine till last week.
Go to the top of the page
 
+Quote Post
Florian
post Mar 19 2016, 10:50
Post #5


Developer


Group: Admin
Posts: 8085
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.84e



Hey all,

thanks for the error reports. This is what happened:
  1. Discogs changed the API access to be HTTPS-only on March 14. Please see the corresponding announcement on the Discogs API Forums. This implies, that all Discogs Tag Sources now need to use HTTPS, i.e., https://api.discogs.com.
    I've updated the official Discogs Tag Source that ships with Mp3tag to use HTTPS (see the release notes for v2.74). Other Tag Sources that are published via the forums need to be updated by their corresponding authors/developers.
  2. The Discogs servers use TLS 1.2 for SSL connections, which is unfortunately not available on Windows XP. It seems, that people who use Mp3tag under Windows XP cannot access the Discogs API as of March 14, 2016.
Please let me know whether you can confirm that you use Mp3tag v2.75, updated the tag source to use HTTPS instead of HTTP and use Windows XP?

Kind regards
Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
Rephlex
post Mar 19 2016, 11:43
Post #6


Member


Group: Full Members
Posts: 19
Joined: 6-April 10
Member No.: 12227
Mp3tag Version: 2.75



Hi Florian!

Thanks for the reply. I'm using version 2.75 of Mp3Tag & Windows 10.

The original Discogs search seems to work [discogs.src], so will use that for now.
Couldn't update the Pone ones as they haven't been updated since 2014 [bummer!].
Hopefully Pone will be fixed someday...

Keep up the good work, Florian!
Thanks again for your awesome program.

This post has been edited by Rephlex: Mar 19 2016, 11:43
Go to the top of the page
 
+Quote Post
pewe
post Mar 19 2016, 14:01
Post #7


Member


Group: Full Members
Posts: 26
Joined: 6-January 08
Member No.: 6250
Mp3tag Version: V2.38



Hi Florian,

seit gestern hab ich mir nen Wolf gesucht und herumprobiert, am Ende alles noch mal neu installiert - null Effekt = 401 Unauthorized remained to come up mad.gif sad.gif

THANKS A TON FOR THIS VERY ADVISE! This is something I can understand. Now, I simply changed HTTP into HTTPS (search for api) in every single Discogs Pone .src contained in SOURCES folder. This is much less work than stabbing around in the dark ... It works! until some professional takes pity on a Discogs Pone update ... rolleyes.gif

Nochmals besten Dank!
Pewe

This post has been edited by pewe: Mar 19 2016, 15:04
Go to the top of the page
 
+Quote Post
Rephlex
post Mar 19 2016, 15:57
Post #8


Member


Group: Full Members
Posts: 19
Joined: 6-April 10
Member No.: 12227
Mp3tag Version: 2.75



Great! Changing http into https in the pone scripts using Notepad [with edit > replace all] solved it for me as well.

Thanks so much pewe!

This post has been edited by Rephlex: Mar 19 2016, 16:13
Go to the top of the page
 
+Quote Post
michael_funk
post May 25 2016, 15:30
Post #9


Member


Group: Full Members
Posts: 31
Joined: 18-July 06
Member No.: 3451
Mp3tag Version: 2.43



Hi all!

I'm sorry I have to report that neither version 2.73 nor version 2.77 work with discogs, be it http://api.... or https://api....

I get the unauthorized-message in any combination of the above.

I'm using Win7 Professional 64bit.

Kind regards,
Michael

Edit:
I have to correct myself:
  • discogs.src is working, when changing http to https (never used this one rolleyes.gif)
  • The scripts in discogs_extended_21.zip will not work, wether in a http or https version. How do these scripts have to be updated?


This post has been edited by michael_funk: May 25 2016, 15:45
Go to the top of the page
 
+Quote Post
ohrenkino
post May 26 2016, 07:13
Post #10


Member


Group: Full Members
Posts: 9153
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.84d



Did you look at
https://forums.mp3tag.de/index.php?showtopi...amp;#entry90568
?


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
michael_funk
post May 27 2016, 10:47
Post #11


Member


Group: Full Members
Posts: 31
Joined: 18-July 06
Member No.: 3451
Mp3tag Version: 2.43



ZITAT(ohrenkino @ May 26 2016, 08:13) *


Thank you ohrenkino!
I missed that one. I added the "[UserAgent]=1" line to all the scripts and with https and that line they are all working again.

Thank you for pointing me in the right direction.
Go to the top of the page
 
+Quote Post
ricky
post Aug 12 2016, 15:53
Post #12


Member


Group: Full Members
Posts: 13
Joined: 29-March 14
Member No.: 19265
Mp3tag Version: 2.78



I'm using Mp3Tag 2.78 in win10 x64
and today I get "401 : UNAUTHORIZED" in discogs:


In the discogs.src (which is intact, as it ships with the installer) the entries mentioned above have these values:
CODE
[UserAgent]=1
[Encoding]=url-utf-8

I've also tried replacing all http with https in the discogs.src but it didn't fix the issue.

This post has been edited by ricky: Aug 12 2016, 16:35
Go to the top of the page
 
+Quote Post
ohrenkino
post Aug 12 2016, 17:05
Post #13


Member


Group: Full Members
Posts: 9153
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.84d



ZITAT(ricky @ Aug 12 2016, 16:53) *
I'm using Mp3Tag 2.78 in win10 x64
and today I get "401 : UNAUTHORIZED" in discogs:


In the discogs.src (which is intact, as it ships with the installer) the entries mentioned above have these values:
QUELLTEXT
[UserAgent]=1
[Encoding]=url-utf-8

I've also tried replacing all http with https in the discogs.src but it didn't fix the issue.

What about the firewall?
In Mp3tag try Help>Look for updates
You should get a message box: either there are no updates or there is one.
If you do not get a message box then MP3tag has no internet access and is blocked most likely by your firewall.


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
ricky
post Aug 12 2016, 17:13
Post #14


Member


Group: Full Members
Posts: 13
Joined: 29-March 14
Member No.: 19265
Mp3tag Version: 2.78



QUOTE (ohrenkino @ Aug 12 2016, 19:05) *
What about the firewall?
In Mp3tag try Help>Look for updates
You should get a message box: either there are no updates or there is one.
If you do not get a message box then MP3tag has no internet access and is blocked most likely by your firewall.

Thanks for replying.

No, it's not blocked by the firewall. It shows "You are using the latest version. An update is not available".

I just noticed that the issue only occurs if the query contains the dash ('-' ) character.
e.g.
with "Star Wars IV - A New Hope" :

it occurs,
but
with "Star Wars IV A New Hope" it shows results as expected.

So I suggest the fix to such cases would be the query to be submitted by Mp3Tag to discogs site having all dash characters escaped ( "Star Wars IV \- A New Hope")

This post has been edited by ricky: Aug 12 2016, 17:27
Go to the top of the page
 
+Quote Post
Mal'Ganis
post Jan 13 2017, 05:34
Post #15


Member


Group: Full Members
Posts: 5
Joined: 17-October 15
From: Portugal
Member No.: 21287
Mp3tag Version: 2.72



I've been having this error with Mp3tag 2.80. I did replace each "http" for "https" inside the sources file but the problem remains.

I was using old configuration files hence the problem. Solved! smile.gif

This post has been edited by Mal'Ganis: Jan 13 2017, 05:39
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2017 - 10:35