IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> [F] Corruption on non-ASCII characters in WAV tag, v2.83
chrisjj
post Aug 2 2017, 02:01
Post #1


Member


Group: Full Members
Posts: 1531
Joined: 25-October 05
Member No.: 2273
Mp3tag Version: -



UPDATED.

Thanks Florian for adding WAV support, but...

I find that a WAV file with a tag field created with GoldWave and having non-ASCII character displays fine in Windows 7 Explorer, but in Mp3tag displays truncated e.g.



It displays fine in dBpowerAmp too http://i.imgur.com/85KgTno.png .

Such a tag created in Mp3tag works fine, but presumably that's because Mp3tag is storing in a different format - INAM + ID3.

Here's the binary:



This isn't just display. Export shows the corruption. I'd guess all Mp3tag operations suffer.

This failure doesn't happen when the format is WMA and MP3.

Thoughts?

This post has been edited by chrisjj: Aug 2 2017, 12:14
Go to the top of the page
 
+Quote Post
chrisjj
post Aug 14 2017, 21:25
Post #2


Member


Group: Full Members
Posts: 1531
Joined: 25-October 05
Member No.: 2273
Mp3tag Version: -



Florian, do you plan to fix this?
Go to the top of the page
 
+Quote Post
Florian
post Aug 15 2017, 09:15
Post #3


Developer


Group: Admin
Posts: 8142
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.85f



Can you please upload a small file which exemplifies this issue?

Kind regards
– Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
chrisjj
post Aug 16 2017, 20:54
Post #4


Member


Group: Full Members
Posts: 1531
Joined: 25-October 05
Member No.: 2273
Mp3tag Version: -



Sure - attached is the failing .WAV from the example I gave. Thanks.
Attached File(s)
Attached File  2_Untitled1_save_by_GW_6.30___title_truncated_in_Mp3tag.wav ( 176.08K ) Number of downloads: 35
 
Go to the top of the page
 
+Quote Post
Florian
post Aug 17 2017, 14:11
Post #5


Developer


Group: Admin
Posts: 8142
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.85f



Thanks all for the example file. I've fixed the issue with the latest Development Build Mp3tag v2.83i.

Kind regards
– Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
chrisjj
post Aug 17 2017, 21:23
Post #6


Member


Group: Full Members
Posts: 1531
Joined: 25-October 05
Member No.: 2273
Mp3tag Version: -



Thanks. I confirm that instance is fixed.



And others too. http://i.imgur.com/je4lbFn.png

But I've found other issues with this version tagging WAV.

1) Some tags missing http://i.imgur.com/P2u3aX0.png . I have not yet reliably reproduced this.

2) Some files taking tag from a different file! http://i.imgur.com/rUfJbEL.png I have not yet reliably reproduced this.

3) Tags unreadable in MediaMonkey V4.1.3.1708 . Reported here https://forums.mp3tag.de/index.php?showtopic=22803 .

This post has been edited by chrisjj: Aug 18 2017, 01:12
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th December 2017 - 18:39