IPB

Welcome Guest ( Log In | Register )

> Hinweise!

Bitte vor dem erstellen eines Beitrag unbedingt die Häufig gestellten Fragen lesen und die Suche verwenden.

Bitte lesen Sie auch die allgemeinen Nutzungsbestimmungen dieses Forums.

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Coverbilder werden auf Musikplayern + Smartphone nicht angezeigt
mucke
post Mar 24 2015, 17:52
Post #1


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



Habe in wochenlanger Kleinarbeit meine große mp3-Sammlung (rund 1500 Titel an der Zahl) per Mp3tag wie folgt mit Covern versehen:

1. mp3-Datei in Mp3tag geöffnet
2. Coverbild auf discogs gesucht und auf Rechner kopiert
3. mp3 in Mp3tag markiert und per Rechtsklick unten links "Cover hinzufügen" gewählt, das gespeicherte Coverbild von discogs gewählt und es als "Front Cover" definiert.
4. gespeichert.

Bis hierhin war alles wunderbar. Auf meinen Rechnern werden nun alle so mit Coverbildern versehenen mp3's korrekt angezeigt (sowohl im Windows Media Player 12 als auch im VLC media player). Siehe screenshot.

5. Abschließend Übertragung der o bearbeiteten mp3 per Windows Explorer auf meine diversen Sony-Musikplayer und aufs Smartphone.

Ergebnis: Auf allen Musikplayern als auch dem Smartphone werden sie zu ca. 99% nicht angezeigt sad.gif Nur bei ganz wenigen erscheint ein Coverbild.

Zuerst dachte ich, es könne an der Übertragung per Windows Explorer liegen, das da die Coverbilder irgendwie verloren gingen. Ist aber nicht so. Nach Quercheck, sprich Öffnen der files auf den diversen Playern am angeschlossenen PC werden die Cover nach wie vor alle angezeigt. Nur eben bei der Wiedergabe am Player oder Smartphone nicht. Auch kamen ja alle Bilder von discogs und hatten entsprechende passende Größen und Abmessungen.

Nun weiß ich nicht mehr weiter und bin ziemlich frustriert wegen der wochenlangen Kleinarbeit, die letztendlich umsonst war.

Habe ich was verkehrt gemacht oder woran könnte es sonst liegen?
Attached thumbnail(s)
Attached Image
 
Go to the top of the page
 
+Quote Post
ohrenkino
post Mar 24 2015, 21:52
Post #2


Member


Group: Full Members
Posts: 8644
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.83



ZITAT(mucke @ Mar 24 2015, 17:52) *
.. Nur bei ganz wenigen erscheint ein Coverbild...

Und worin unterscheiden sich die mit Bild von denen ohne Bilddarstellung?


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
mucke
post Mar 25 2015, 11:47
Post #3


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



QUOTE (ohrenkino @ Mar 24 2015, 21:52) *
Und worin unterscheiden sich die mit Bild von denen ohne Bilddarstellung?


Daran hatte ich auch schon gedacht. Ich kann aber keine Unterschiede feststellen. Die embedded pics sind wie alle anderen *.jpg-Dateien und bezüglich Dateigröße und Abmessungen wie alle anderen auch.

(PS: Wie bekomme ich hier denn beim schreiben einen Zeilenumbruch hin?)
Go to the top of the page
 
+Quote Post
ohrenkino
post Mar 25 2015, 12:05
Post #4


Member


Group: Full Members
Posts: 8644
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.83



ZITAT(mucke @ Mar 25 2015, 11:47) *
...Ich kann aber keine Unterschiede feststellen. ...(PS: Wie bekomme ich hier denn beim schreiben einen Zeilenumbruch hin?)

(Enter drücken)

Wie überprüfst du, ob die Bilder eingebettet sind? Mit WMP? Oder mit Mp3tag und Filter:
%_covers% PRESENT
?


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
mucke
post Mar 26 2015, 10:00
Post #5


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



QUOTE (ohrenkino @ Mar 25 2015, 12:05) *
Wie überprüfst du, ob die Bilder
eingebettet sind? Mit WMP? Oder mit Mp3tag und Filter: %_covers% PRESENT?


Ganz banal per WMP und (nachdem ich merkte, daß die Bilder auf meinen mobilen Geräten nicht
angezeigt werden) auch noch per VLC. Beide zeigen, wie Eingangs gesagt, alle Bilder ordnungsgemäß
an.


(PS: So, nun habe ich beim Verfassen dieser Antwort in jeder Zeile beim Erreichen des rechten Rands
immer ENTER gedrückt. Nur so sieht man was man schreibt. Finde ich etwas ungewöhnlich und kenne
das auch aus keinem anderen Forum. Liegt wohl an der Forensoftware).

This post has been edited by mucke: Mar 26 2015, 10:08
Go to the top of the page
 
+Quote Post
ohrenkino
post Mar 26 2015, 11:38
Post #6


Member


Group: Full Members
Posts: 8644
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.83



ZITAT(mucke @ Mar 26 2015, 10:00) *
Ganz banal per WMP und (nachdem ich merkte, daß die Bilder auf meinen mobilen Geräten nicht
angezeigt werden) auch noch per VLC. Beide zeigen, wie Eingangs gesagt, alle Bilder ordnungsgemäß
an.


(PS: So, nun habe ich beim Verfassen dieser Antwort in jeder Zeile beim Erreichen des rechten Rands
immer ENTER gedrückt. Nur so sieht man was man schreibt. Finde ich etwas ungewöhnlich und kenne
das auch aus keinem anderen Forum. Liegt wohl an der Forensoftware).

Das mit dem Enter-Drücken sollte nicht notwendig sein.

Zurück zum Thema: WMP speichert Bilder im eigenen Bilder-Cache und in der Datei Folder.jpg. Da ist es ziemlich wumpe, in wievielen Dateien die Bilder enthalten sind, es bekommen alle aus einem Ordner das Bild aus folder.jpg gezeigt.
Wenn jetzt der Abspieler auf dem Smartphone mit folder.jpg nichts anfangen kann, siehst du wirklich nur die Bilder, die es in den Dateien gibt.

Also lade bitte alle Musikdateien in MP3tag und wende den Filter
%_covers% MISSING
an.
Wenn die Dateiliste anschließend leer ist, dann sind wirklich in allen Dateien Bilder eingebettet. Bei jeder gezeigten Datei aber nicht.
Du kannst die Bilder dann mit einer Aktion "Cover aus Datei einfügen" und der Angabe des Dateinamens folder.jpg einbetten.
Anschließend sollte die erneute Anwendung des Filters zu einer leeren Liste führen.
Wenn dem nicht so ist, musst du die Bilder für die Dateien noch mal suchen.


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
mucke
post Mar 26 2015, 16:53
Post #7


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



QUOTE (ohrenkino @ Mar 26 2015, 11:38) *
WMP speichert Bilder im eigenen Bilder-Cache und in der Datei Folder.jpg. Da ist es ziemlich wumpe, in wievielen Dateien die Bilder enthalten sind, es bekommen alle aus einem Ordner das Bild aus folder.jpg gezeigt....


Wir driften leider vom Thema ab. Darum geht es doch nicht.

In meinem Ausgangspost, meine ich alles genau beschrieben zu haben. Es geht nicht um von CD per WMP kopierte ganze Musikalben die dann ein folder.jpg und weitere Mülldateien wie AlbumArt*.jpg in den Verzeichnissen haben (so wie das ein Ingo in seinem Blog hier https://ingoboettcher.wordpress.com/2011/12...richtig-taggen/ unter "Tipps & Tricks" schön beschreibt). So wie er das beschreibt, verfahre ich auch schon länger.

Selbstverständlich habe ich auch ganze CD-Alben auf dem Rechner und den mobilen Playern. Diese mp3s werden auch auf all meinen Playern, inklusive meinem Windows Smartphone korrekt mit Covern angezeigt. Darum geht es also nicht.

Es geht um einzelne mp3s die ich in Ordnern sortiert und dann daraus einzeln getaggt und alle einzeln mit Cover-pics versorgt habe.


(PS: Ich schriebe jetzt nur noch im externen Editor und paste dann hier hinein. Dieser Editior hier nervt ohne Ende. Warum macht der denn keine Zeilenumbrüche?)
Go to the top of the page
 
+Quote Post
ohrenkino
post Mar 26 2015, 17:41
Post #8


Member


Group: Full Members
Posts: 8644
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.83



ZITAT(mucke @ Mar 26 2015, 16:53) *
Wir driften leider vom Thema ab. Darum geht es doch nicht.

ZITAT
Auf allen Musikplayern als auch dem Smartphone werden sie zu ca. 99% nicht angezeigt

ZITAT
...mp3s werden auch auf all meinen Playern, inklusive meinem Windows Smartphone korrekt mit Covern angezeigt. Darum geht es also nicht.

In summe ein bisschen schwierig zu verstehen, wenn man sich nur auf die Mitteilungen hier verlassen muss.
ZITAT
Es geht um einzelne mp3s die ich in Ordnern sortiert und dann daraus einzeln getaggt und alle einzeln mit Cover-pics versorgt habe

Wieso beantwortest du nicht die Frage nach dem Filterergebnis? Gerade beim Einsatz von Abspielern mit Datenbank im Hintergrund gibt es Überraschungen hinsichtlich Bildern.
Wenn du ein Windows Phone benutzt, unterstelle ich, dass dies einen ähnlichen Mechanismus wie ein Windows Media Player anwendet. Also müssen die folder.jpg Dateien mit.
Da es pro Ordner nur eine folder.jpg Datei geben kann, müssten alle Dateien, die sich beim Bild unterscheiden, in einem eigenen Ordner untergebracht werden.


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
C-S-T
post Mar 31 2015, 12:50
Post #9


Member


Group: Full Members
Posts: 16
Joined: 4-December 12
Member No.: 17254
Mp3tag Version: V2.69



ZITAT(mucke @ Mar 26 2015, 17:53) *
Es geht um einzelne mp3s die ich in Ordnern sortiert und dann daraus einzeln getaggt und alle einzeln mit Cover-pics versorgt habe.


zum verständnis: du hast, sagen wir mal, einen einzigen ordner "meine sammlung", in dem x mp3-dateien liegen. in mp3tag werden alle dateien mit cover gezeigt. außer den mp3-dateien befinden sich keinerlei anderen dateien (bilder) im ordner. bei allen mp3-dateien wird bei verwendung eines pc-players (wmp, vlc, kmp usw.) das cover angezeigt.

wenn dem so ist, muss es einen zusammenhang bei den dateien geben. sind id3v1 und id3v2 vorhanden? ggf. auch noch ape? befinden sich zu viele (unnötige) tags in den dateien? wie groß sind die cover und immer nur eines?

es kann durchaus noch möglich sein, dass sich auch fehlerhafte einträge im id3-tag befinden, deshalb auf jeden fall die dateien mit mp3diags prüfen lassen.

ps: mein editor macht textumbrüche (firefox 36)

This post has been edited by C-S-T: Mar 31 2015, 12:56
Go to the top of the page
 
+Quote Post
MisterK
post Apr 12 2015, 20:39
Post #10


Member


Group: Full Members
Posts: 16
Joined: 12-April 15
Member No.: 20682
Mp3tag Version: 2.69



@mucke:

Hast du eine Lösung gefunden? Ich habe ein ähnliches Problem (siehe Beitrag von mir).

Gruß

Martin
Go to the top of the page
 
+Quote Post
mucke
post Apr 29 2015, 21:52
Post #11


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



(Sorry für die lange Abwesenheit hier. War zu sehr mit beruflichen Dingen beschäftigt.)

Also; Zu eurer Info. Ich habe nun zumindest die Ursache fürs Problem gefunden:

Alle von mir auf discogs, Amazon oder sonstwo gefundenen und auf Festplatte gespeicherten Cover (jpg's) landen irgendwie korrupt(!) auf meiner Festplatte.

Herausgefunden habe ich es mit Hilfe des Bildbetrachter "XnView", nach ewigem Gesuche und Herumprobiere.

Die heruntergeladenen/auf Festplatte gespeicherten Cover sind alle jpg's mit 96 x 96 dpi. So zeigt es mir der Windows Explorer in den Dateieigenschaften an.

"XnView" jedoch zeigt mir in den Dateieigenschaften einen Wert von

??? x ??? dpi

Genau hier lag bei mir das Problem. Sobald ich für diese jpg's in "XnView" den DPI-Wert auf 96 x 96 einstellte und das jpg neu abspeicherte und anschließend die mp3-Datei erneut per mp3tag mit dem nun editierten jpg-Cover versah, wurde das Cover auch auf den mobilen Geräten (Smartphone und Mp3-Player) angezeigt. Juchhuu!

Eine workaround habe ich somit wohl gefunden, allerdings arbeits- und zeitintensiv, da jedes einzelne jpg aus dem Internet manuell nachbearbeitet werden muß.

Warum die jpg's von discogs und Co. allerdings vermeintlich "korrupt" sind, hier mit fehlenden korrekten DPI-Angaben ist mir ein Rätsel.

Ich habe alles nach dem System "trial and error" ausprobiert. D.h. mehrere Rechner/Notebooks ausprobiert, mehrere Browser, mehrere verschiedene Internetleitungen, und auch temporär alle Anti-Viren-Tools und Firewalls beim Download der jpg's deaktiviert. Ergebnis:

Alle jpg-Cover von discogs und Co. landen bei mir korrupt auf der Platte, alle mit ??? x ??? in den DPI-Angaben.

Nun kann ich mir nur noch ein Problem mit "Windows 7 Home Premium" vorstellen, welches bei all meinen Test verwandt wurde. Ansonsten habe ich keinerlei Erklärung dafür.

Hatte jemand ähnliche Erfahrungen?


PS: Ich habe gerade auch mal den Entwickler von XnView angeschrieben. Mal sehen, was der dazu sagt (wenn er überhaupt antwortet).
Go to the top of the page
 
+Quote Post
mucke
post Apr 29 2015, 22:01
Post #12


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



QUOTE (ohrenkino @ Mar 26 2015, 17:41) *
Wieso beantwortest du nicht die Frage nach dem Filterergebnis?


Mit diesen Filtergeschichten kenne ich mich einfach nicht aus, sorry. Ich benutze Mp3tag völlig manuell. Das ist sicherlich viel zu umständlich, aber mir fehlt auch eine ordentliche und vor allem vollständige Hilfe zum Programm. Vieles ist einfach nicht erklärt. Aber egal; Darum geht es in diesem Thema ja auch nicht.


QUOTE (ohrenkino @ Mar 26 2015, 17:41) *
Gerade beim Einsatz von Abspielern mit Datenbank im Hintergrund gibt es Überraschungen hinsichtlich Bildern.
Wenn du ein Windows Phone benutzt, unterstelle ich, dass dies einen ähnlichen Mechanismus wie ein Windows Media Player anwendet. Also müssen die folder.jpg Dateien mit.
Da es pro Ordner nur eine folder.jpg Datei geben kann, müssten alle Dateien, die sich beim Bild unterscheiden, in einem eigenen Ordner untergebracht werden.


Ich wiederhole: Es hat wirklich nichts mit Folder.jpg's zu tun. Siehe meine gefundene Ursache des Problems.
Go to the top of the page
 
+Quote Post
mucke
post Apr 29 2015, 22:03
Post #13


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



QUOTE (C-S-T @ Mar 31 2015, 12:50) *
ps: mein editor macht textumbrüche (firefox 36)


Und bei mir rutscht der Text nach wie vor ruck-zuck nach rechts aus dem Fenster heraus und man kann nicht mehr sehen, was man schreibt :-(
Go to the top of the page
 
+Quote Post
ohrenkino
post Apr 30 2015, 06:26
Post #14


Member


Group: Full Members
Posts: 8644
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.83



ZITAT(mucke @ Apr 29 2015, 23:01) *
Mit diesen Filtergeschichten kenne ich mich einfach nicht aus, sorry. Ich benutze Mp3tag völlig manuell. Das ist sicherlich viel zu umständlich, aber mir fehlt auch eine ordentliche und vor allem vollständige Hilfe zum Programm. Vieles ist einfach nicht erklärt. ...

Der Filter ist post#4 genannt.
Die Filterfunktion ist in der Hilfe erklärt - einfach mal F1 drücken und schon hat man Lektüre für einige Zeit.

Zu den anderen Problemen: Es bleibt festzuhalten, dass du mit deinem System Probleme beim Zugriff auf das Internet hast:
- die Bilder werden durch download zerstört (was absolut erstaunlich ist, da zur Anzeige die Bilder ja auch runtergeladen werden mussten)
- der Editor verhält sich nicht so, wie beim Rest der Welt und weigert sich Umbrüche zu machen...

Ich würde jetzt mal sehen, was sonst noch an deinem System bzw. dem Browser kaputt ist, bevor da weitere Daten manipuliert werden. Deshalb meine ich, dass die Probleme ausschließlich lokaler Natur sind, aber nicht auf MP3tag zurückzuführen sind.


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
mucke
post Apr 30 2015, 13:23
Post #15


Member


Group: Full Members
Posts: 11
Joined: 24-March 15
Member No.: 20602
Mp3tag Version: 2.77



Es kann doch nicht an meinem System bzw. Rechner liegen, da dieses Phänomen bei all unseren Rechnern auftritt. Das habe ich aber bereits oben geschrieben.

Ich wiederhole: Ich habe es mit insgesamt 3 verschiedenen Rechnern (Notebooks) an verschiedenen Internetleitungen und auch mit verschiedenen Browsern ausprobiert!

Die heruntergeladenen/gespeicherten jpg's landen immer ohne dpi-Information auf den Festplatten (zumindest laut Anzeige im Programm XnView). Der Windows Explorer zeigt ja dpi-Information an.

Ich stimme dir allerdings zu, daß es wohl kein Problem von Mp3Tag ist.

Trotzdem hatte ich gehofft, hier in diesem Forum eine Erklärung dafür zu finden. Schade.


(PS: Hier gibt es einen Button "switch between standard and rich text editor". Da passiert bei mir aber nichts. Vielleicht liegt es daran? So muß ich meine Antworten weiterhin im externen Texteditor schreiben und dann hier hinein pasten. Sonst könnte ich die hier weder lesen noch formatieren.)
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th June 2017 - 02:53