IPB

Welcome Guest ( Log In | Register )

> Notice!

Please take a minute to check our Frequently Asked Questions. Use Search to reveal possible related topics.

Also make sure you've read the Forum Guidelines before posting in this forum.

Abbreviations: (will be specified by moderators/administrators)

 
Reply to this topicStart new topic
> MP4 (m4a) tags not loaded after beaTunes analyze the file
joephein
post Feb 28 2017, 18:03
Post #1


Member


Group: Members
Posts: 3
Joined: 28-February 17
Member No.: 23133
Mp3tag Version: 2.81



I am using beaTunes to analyze my music collection and add tags, mood and color to the files.
After beaTunes saves the changes mp3tag cannot load the MP4 tag info anymore.

Attached Image


This is only repro for m4a files. I confirm that Windows Media Player, Windows Explorer, or TagRename can read the tags successfully.
See attached screenshot for more details:

Attached Image


If you need any demo files to repro and investigate please send me a message.

This post has been edited by joephein: Mar 2 2017, 08:30
Go to the top of the page
 
+Quote Post
ohrenkino
post Feb 28 2017, 18:20
Post #2


Member


Group: Full Members
Posts: 8876
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.83k



ZITAT(joephein @ Feb 28 2017, 18:03) *
I am using beaTunes ...

I don't know what this software does. But if it transforms the MP4 tags to nero layout then this is a known issue. Nero tags are not compliant with the MP4 standard and MP3tag does not support them.


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
joephein
post Feb 28 2017, 21:06
Post #3


Member


Group: Members
Posts: 3
Joined: 28-February 17
Member No.: 23133
Mp3tag Version: 2.81



beaTunes closely works together with iTunes to create playlists. I do not believe it uses the nero layout format. Can you repro the issue with the m4a that I shared? Is there any way to debug using the files what can be the cause?
Go to the top of the page
 
+Quote Post
ohrenkino
post Feb 28 2017, 21:51
Post #4


Member


Group: Full Members
Posts: 8876
Joined: 9-December 09
From: Norddeutschland / Northern Germany
Member No.: 11458
Mp3tag Version: 2.83k



ZITAT(joephein @ Feb 28 2017, 21:06) *
... Can you repro the issue with the m4a that I shared?...


There is a known issue with nero tags.
You have a certain work environment that leads to you reporting a bug.
I would say that right now it is up to you to show that this is a completely new case.
I think that such reports are marked [AF]: awaiting feedback.

This post has been edited by ohrenkino: Feb 28 2017, 21:52


--------------------
42 - wie war die Frage / what was the question / quelle était la question
Go to the top of the page
 
+Quote Post
joephein
post Mar 1 2017, 17:17
Post #5


Member


Group: Members
Posts: 3
Joined: 28-February 17
Member No.: 23133
Mp3tag Version: 2.81



I would then conclude that the root cause is a not well documented (standardized) specification of how tags are used in MP4 files by Apple. What fixed it for me is running the dBpoweramp [ID Tag Update] Utility Codec to fix the tags. Any additional edits by beaTunes to the tags are fine and not causing any issues.

  • Use the dBpoweramp [ID Tag Update] Utility Codec to fix the tags
  • Run beaTunes analyze to sort out any tag issues and add the special tags to the files
  • mp3tag can read the tags fine now even after beaTunes edits the tags, while this was previously causing the issue.


It is probably a combination of factors. However mp3tag was the only tool that had problems to read the tags. Feel free to close this as Not a bug (By Design)

This post has been edited by joephein: Mar 2 2017, 08:31
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2017 - 07:19