IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Set TRACK in scripts HACK., Doing 'set' fn doesn't have any effect.
stevehero
post Apr 25 2017, 02:04
Post #1


Member


Group: Full Members
Posts: 827
Joined: 3-December 10
From: Ireland
Member No.: 13334
Mp3tag Version: 2.84



If you place this at the end of your script...

CODE
set "TRACK"

You will still get the TRACK in the main tag info window resulting in it tagging the TRACK TAG.

There's a solution by placing 500, for example (Which should be enough), |'s at the end of your script like so in conjunction with # set "TRACK" (Optional) if you place that option at the end:

CODE
    outputto "track"
    say "||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
|
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
|
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
|
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
|
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
|
|||||||||||||||||||"

# set "TRACK"


I'm pretty sure this may be a bug. But, I'm not certain. Anyway, here lies a solution.

Can someone test and report back if it's okay?

This post has been edited by stevehero: Apr 25 2017, 02:07


--------------------
Go to the top of the page
 
+Quote Post
Florian
post Jul 1 2017, 19:17
Post #2


Developer


Group: Admin
Posts: 8044
Joined: 12-December 01
From: Germany, Dresden
Member No.: 203
Mp3tag Version: 2.84b



QUOTE (stevehero @ Apr 25 2017, 03:04) *
Can someone test and report back if it's okay?

It's not. Can you check if you're really using
CODE
set "TRACK"

to clear the content of the "TRACK" output buffer in your script (without the #, which would comment out this line).

Kind regards
– Florian


--------------------
♫ If you like using Mp3tag please donate to support further development.

Go to the top of the page
 
+Quote Post
stevehero
post Jul 2 2017, 00:09
Post #3


Member


Group: Full Members
Posts: 827
Joined: 3-December 10
From: Ireland
Member No.: 13334
Mp3tag Version: 2.84



QUOTE (Florian @ Jul 1 2017, 19:17) *
It's not. Can you check if you're really using
CODE
set "TRACK"

to clear the content of the "TRACK" output buffer in your script (without the #, which would comment out this line).

Kind regards
– Florian

I was sure that this was occurring with a previous version.

I 100% had the TRACK set.

Seems fine now.


--------------------
Go to the top of the page
 
+Quote Post
pone
post Jul 26 2017, 00:49
Post #4


Member


Group: Full Members
Posts: 1692
Joined: 15-March 09
From: Germany
Member No.: 9103
Mp3tag Version: 2.59b



Easier and working fine with my discogs scripts:

QUELLTEXT
# Delete TITLE Field
set "title"
outputto "title"
say "|"    

# Delete TRACK Field
set "track"
outputto "track"
say "|"



I did quite a lot of testing until I had it going. I think I remember it's important to use the two command blocks in this order to get both working. And to use it at the very end of the script.
Go to the top of the page
 
+Quote Post
stevehero
post Jul 26 2017, 13:04
Post #5


Member


Group: Full Members
Posts: 827
Joined: 3-December 10
From: Ireland
Member No.: 13334
Mp3tag Version: 2.84



QUOTE (pone @ Jul 26 2017, 00:49) *
Easier and working fine with my discogs scripts:

CODE
# Delete TITLE Field
set "title"
outputto "title"
say "|"    

# Delete TRACK Field
set "track"
outputto "track"
say "|"



I did quite a lot of testing until I had it going. I think I remember it's important to use the two command blocks in this order to get both working. And to use it at the very end of the script.

So the initial bug find is there you think?

I've been busy so haven't had time to source the script which I had problems with. Think I may have deleted it.

CODE
set "TRACK"

doesn't work


--------------------
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd September 2017 - 16:26